200cm3 (Стаканыч)

Диагностика своими руками

6 525 сообщений в этой теме

Shr-lnm    859
53 minutes ago, Andrey D said:

может попробовать 2710168? 

У них видимо месяц ровно 30 дней

Конечно попробуйте 27100168

 

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
GziN    24

 

Тупанул что то. Показывает как у вас.

IMG_20160507_160321.jpg

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Andrey D    37

Да, 360 оказалось 12 месяцев)) Все получилось. Спасибо за помощь. 

Тыкните носом, где подсказки, чтобы создать bat'ник запуска скрипта, чтобы не набирать каждый раз пути и параметры

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Andrey D    37

Наткнулся еще на одну интересную штуку... Звуковой сигнализатор при закрывании замков. В параметрах указано, что "С", а звукового сигнала нет. При включении этого параметра ничего не меняется и звука нет.

1.jpg

2.jpg

3.jpg

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
2 hours ago, Andrey D said:

где подсказки, чтобы создать bat'ник запуска скрипта, чтобы не набирать каждый раз пути и параметры

Я сделал так:

1. Создал ярлык на рабочем столе и в первом окошке ввел cmd.exe

2. во втором окошке указываешь имя ярлыка, например "PyRen"

3. в третьем окошке делаешь так:

faGaxH4JT https://cloud.mail.ru/public/Mbig/faGaxH4JT

т.е. в поле объект вводишь %comspec% /k "pyren.py -p COMx --demo"

а в поле рабочая папка, путь к папке со скриптом

2 hours ago, GziN said:

Показывает как у вас.

Тогда даже не знаю куда дальше копать ((((

1 hour ago, Andrey D said:

В параметрах указано, что "С", а звукового сигнала нет. При включении этого параметра ничего не меняется и звука нет.

Может это для другой модификации проводки или прошивки???

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
gruzdev_f    40

это скорей всего работает у авто с штатной сигналкой, там под стеклом дополнительный гудок

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
GziN    24

Переустановил полностью python. Теперь все по русски но вот такие ошибки.

Screenshot_3.png

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
1 hour ago, GziN said:

Переустановил полностью python. Теперь все по русски но вот такие ошибки.

 Думаю ничего страшного не случится если сделать то, что он предлагает.

python -m pip install --upgrade pip

еще для XP можно в файле pyren.py закоментарить строчки с 15 по 24. Они тогда должны выглядеть вот так

 

#  try:
#    import psutil
#  except ImportError:
#    pip.main(['install','psutil'])  
#    try:
#      import psutil
#      p = psutil.Process(os.getpid())
#      p.nice(psutil.HIGH_PRIORITY_CLASS)
#    except ImportError:
#      pass

 

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

Ребят, уже проверил у себя три ELM327, и все типа не видят кан шину.
в логах на at sp 6 пишут ок, а на 0210С0 - CAN ERROR. это точно проблема в адаптерах?

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0
21 час назад, amokk_spb сказал:

какие версии использовали?

1. Скачайте SL4A Application, файл sl4a-r6.1.1-arm-debug.apk 
2. Скачайте Py4A Application, файл PythonForAndroid-debug.apk

и это сделано:

6. Откройте PythonForAndroid
7. Нажмите Install для загрузки и установки необходимых библиотек Python.

?

Переустановил согласно Ваших ссылок - результат тот же. Попробовал на другом смартфоне - S3 samsung - базовые скрипты работают - похоже дело в железе. Завтра попробую Pyren - результат выложу. Всем огромное спасибо.

 

с Philips W732 запустить скрипты так и не получилось. Samsung galaxy s3 duos - Pyren полет нормальный.

Изменено пользователем Lobster66

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
48 minutes ago, Alеxey said:

Ребят, уже проверил у себя три ELM327, и все типа не видят кан шину.
в логах на at sp 6 пишут ок, а на 0210С0 - CAN ERROR. это точно проблема в адаптерах?

А дайте эти логи посмотреть... Вообще CAN ERROR врядли из-за адаптера, тем более что вы три разных попробовали. Никакого доп оборудования на шину не вешали?

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
GziN    24
12 часов назад, Shr-lnm сказал:

 Думаю ничего страшного не случится если сделать то, что он предлагает.

python -m pip install --upgrade pip

Обновил и теперь опять кривые буквы.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
1 hour ago, GziN said:

Обновил и теперь опять кривые буквы.

Неожиданно ?? !! Но зато теперь понятно откуда берется кривые буквы. PIP до 8.1.1 обновлять не нужно.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
GziN    24

Как теперь  откатить назад? Переустановить python.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
4 minutes ago, GziN said:

Как теперь  откатить назад? Переустановить python.

попробуйте сначала вот так

 python -m pip install pip==7.1.2

если не получится, то тогда наверное только переустановка, благо что не очень долго ставится...

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Andrey D    37
18 часов назад, gruzdev_f сказал:

это скорей всего работает у авто с штатной сигналкой, там под стеклом дополнительный гудок

так у меня, вроде как, стоит штатная, с объемниками. Если окно оставить и руку засунуть, то орать начинает. И под жабо, справа, есть пищалка.

 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7
16 часов назад, Shr-lnm сказал:

А дайте эти логи посмотреть... Вообще CAN ERROR врядли из-за адаптера, тем более что вы три разных попробовали. Никакого доп оборудования на шину не вешали?

гляньте. доп оборудования на шине нет, клип работает исправно

вообще все адаптеры свежие, может быть там реально не было PIC контроллера?

PS: просевтил корпус фонариком, внуренности оч похожи на эти
http://renault-symbol-club.ru/forum/download/file.php?id=15192&t=1&sid=f2953c8f093d2d6da1c8362a3f9c6d2b

посоветуйте, как заставить работать.

1.rar

Изменено пользователем Alеxey

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
4 minutes ago, Alеxey said:

вообще все адаптеры свежие, может быть там реально не было PIC контроллера?

Судя по логам, адаптеры поддерживают необходимые команды - дело наверное не в них.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

а если тестером шину посмотреть, что показывает?

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

ну скажите что посмотреть, тестер в багажнике лежит.
клип то по этой шине работает?

6 пин к земле 2.49В
14 пин к земле 2.21В

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

Они должны быть симметричны относительно 2.5в а у вас симметрии не получается. Я правда не знаю допустимых пределов. Возможно в эбу логика получше устрена и им эта асимметрия не мешает а elm  попроще. Но это только мои умозрительные заключения - пусть специалисты меня поправят

Сейчас схожу ради интереса на своей посмотрю

 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

я мерил с землей (4 или 5 пин) на заглушенной авто.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

У меня 

6пин 2.4

14пин 2.2

Видимо дело не в этом

 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
6 hours ago, Alеxey said:

1.rar

А это логи от разных адаптеров? Во всех этих логах скрипт находит 7 блоков. Но так как эбу двигателя должен отвечать по CAN а тут отвечает по K-линии, скрипт его не показывает.

Если у вас эти адаптеры USB, то можно посмотреть видят ли они хоть что-нибудь на CAN в режиме монитора.

https://github.com/shrlnm/CanBusMonitor

 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
quattro81    128

мне тут недавно попались очень интересные экземпляры елмов. На atz отзывается v1.5, на atpps, atkw, atfe и т.п. выдает ? Самое интересное на atrv выдает 36,6 в даже без подключения к авто, при подключении тоже самое. Прикол в том, что терминал в проге сканмастер с этими элмами не смог пообщаться и обычный виндовый терминал тоже. Только елмчат под андройд соединился с ними и команды послать можно стало. Подключался к мазде cx7 ошибок не показывает прога сканмастер елм, хотя горит чек. Взял свой нормальный елм, сканмастер нашел 2 ошибки по лямбде p0034 и p132, стандартные ошибки. И форскан их же показал. А этот левый елм даже через сканмастер ничего не увидел, хотя параметры - обороты, температура и т.п. показывал. Вот такой левак идет под видом 1.5

Будьте бдительны при покупке.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
9 minutes ago, quattro81 said:

на atrv выдает 36,6

В чувстве юмора им не откажешь )))

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7
1 час назад, Shr-lnm сказал:

А это логи от разных адаптеров? Во всех этих логах скрипт находит 7 блоков. Но так как эбу двигателя должен отвечать по CAN а тут отвечает по K-линии, скрипт его не показывает.

Если у вас эти адаптеры USB, то можно посмотреть видят ли они хоть что-нибудь на CAN в режиме монитора.

https://github.com/shrlnm/CanBusMonitor

логи от разных адаптеров! все адаптеры блутус.
не знаю даже че делать...

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

в реальности у меня 10 действующих блоков

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
PyRen    191

С Праздником Победы!!!

pyren_v099_beta.zip http://wikisend.com/download/759606/pyren_v099_beta.zip
MD5 (pyren_v099_beta.zip) = a449812418edda185f20f2e8985f7aed


Исправлено:
- более корректно работает mod_optfile.py (спасибо Valentin8080)
- контроль длины вводимого параметра HEX
- изменена нумерация моделей автомобилей
- при выборе модели не показываются старые, неподдерживаемые модели
- длинные меню адаптированы под маленький экран андроид
Добавлено:
- поддержка FAST/SLOW INIT на k-line (kline-mode2 от Shr-lnm)
- значительно улучшены возможности commander.py (см. пример кода)

Изменено пользователем PyRen

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

2 PyRen нет идей, почему у меня не работает? )

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
PyRen    191

Идей нет, кроме как попробовать эти адаптеры на других машинах. Читают ли они CAN шину?

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

ну я тоже так хочу, пока просто рено знакомых не попадалось :)

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
seit    8

 

 

 

 

pyren_v099_beta

 

C:\GenAppli\pyren>mod_ecu.py 0110536 RU torq
Loading language
Done
Loading optimyzer
Loading defaults
Loading parameters
Loading states
Loading identifications
Loading commands
Loading mnemonics
Traceback (most recent call last):
  File "C:\GenAppli\pyren\mod_ecu.py", line 690, in <module>
    sss = snat[F2A[family]]
KeyError: '01'

mod_ecu.py

F2A = {"1":"7A", "2":"01", "3":"51", "4":"26", "5":"2C", "6":"00", "7":"24", "8":"29", "9":"6E",  


F2A = {"01":"7A", "02":"01", "03":"51", "04":"26", "05":"2C", "06":"00", "07":"24", "08":"29", "09":"6E",  
 


 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
PyRen    191

Спасибо!
Перевыложил

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Ivaness    109
8 часов назад, PyRen сказал:

Перевыложил

А для чего в pyren_4a_launcher.py добавилась строка #sys.argv.append('--scan') , если с функцией справляется #sys.argv.append('--demo') ? А вот языковая #sys.argv.append('--LGB') #switch to english. Remove all FG/SG files from cache directory удалена? Теперь для сканирования обязательно нужно раскомментарить строку #sys.argv.append('--scan')?

Изменено пользователем Ivaness

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
PyRen    191

scan добавил для своего удобства а LGB удалил зря. (хотя там была ошибка, нужен был только один минус).
(Плохая конечно практика, но снова перевыложил, пока форум позволяет редактировать сообщения)
--demo и --scan это совсем два разных ключика. Первый просто отключает работу с ELM а второй игнорирует наличие savedEcus.p.
Для принудительного сканирования, правильно, нужно убрать этот диез.

Изменено пользователем PyRen

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Ivaness    109
5 часов назад, PyRen сказал:

а второй игнорирует наличие savedEcus.p.

Т.е., иными словами, и не создаёт этот-самый savedEcus.p, А значит, пусть жертвуя временем загрузки, исключается возможность подцепить чей-нибудь savedEcus.p, не удалённый перед сканированием другой машины. Этой фишки и не хватало нашему штатному диагносту, который так и не понял, зачем я ему запихнул аж десять этих savedEcus.p (savedEcus.p_04, savedEcus.p_13, savedEcus.p_16 и т.д., по позывным номерам авто нашего парка), и зачем надо постоянно их переименовывать;)  

Изменено пользователем Ivaness

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
30 minutes ago, Ivaness said:

исключается возможность подцепить чей-нибудь savedEcus.p

Для этого --scan как раз и нужен. Если с несколькими машинами работаете, то лучше --scan "гвоздиками к строке запуска прибить" )

 savedEcus.p нужен только для персонального использования ну и в demo потом покопаться.

30 minutes ago, Ivaness said:

Т.е., иными словами, и не создаёт этот-самый savedEcus.p

нет - создает в любом случае.

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0

Добрый день всем!

Прошу помощи - после запуска Pyren не предлагает выбор BT устройства и вылетает после выбора модели авто.

В логе elm_log.txt  написано:   [20:04:14:404] at ws    - я так понимаю это проблемы с BT?

Спасибо!

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
27 minutes ago, Lobster66 said:

В логе elm_log.txt  написано:   [20:04:14:404] at ws    - я так понимаю это проблемы с BT?

Похоже проблема с BT. Проверьте видят ли другие программы типа torque или OhNo этот адаптер. Если другие программы видят, а скрипт нет, то попробуйте перезагрузить телефон. Если и другие не видят, то скорее всего плохо спарен - попробуйте разные PIN  0000 1234  или  5678  

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0
20 минут назад, Shr-lnm сказал:

Похоже проблема с BT. Проверьте видят ли другие программы типа torque или OhNo этот адаптер. Если другие программы видят, а скрипт нет, то попробуйте перезагрузить телефон. Если и другие не видят, то скорее всего плохо спарен - попробуйте разные PIN  0000 1234  или  5678  

Други программы видят. Спарен правильно, перезагрузка не помогает...

Screenshot_2016-05-10-21-12-13.png

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

Тогда нужно проверять правильность установки sl4a и py4a

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

 А вы не из qpython случаем пытаетесь запустить? Из под него я еще ни разу не видел чтобы работало

Изменено пользователем Shr-lnm

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0
21 час назад, Shr-lnm сказал:

 А вы не из qpython случаем пытаетесь запустить? Из под него я еще ни разу не видел чтобы работало

Да из под QPython. Из под обычного вообще скрипты не запускаются хотя устанавливал все по инструкции. Телефон Philipps Xenium W732 Андроид 4.0.3. 

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859

Во время установки питона android обязательно должен предупредить что программа запрашивает доступ к bluetooth и к sd карте . Если этого не происходит то это заведомо не подходящий для скрипта дистрибутив. Qpython из playmarket именно такой. Если быть точным , то в его manifest файле не прописаны эти permissions. Если найдете qpython с правильным манифестом или сами научитесь его править , то возможно скрипт на нем заработает. Но проще еще раз проверить установку по инструкции amokkspb. Ксениум вряд ли виноват - у меня почти такой же

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0
9 часов назад, Shr-lnm сказал:

Во время установки питона android обязательно должен предупредить что программа запрашивает доступ к bluetooth и к sd карте . Если этого не происходит то это заведомо не подходящий для скрипта дистрибутив. Qpython из playmarket именно такой. Если быть точным , то в его manifest файле не прописаны эти permissions. Если найдете qpython с правильным манифестом или сами научитесь его править , то возможно скрипт на нем заработает. Но проще еще раз проверить установку по инструкции amokkspb. Ксениум вряд ли виноват - у меня почти такой же

Все делаю по инструкции, доступ запрашивает  - не работает именно на W732. На телефоне жены все отлично - придется наверное меняться с ней ))).

А если сделать ROOT и дать полный доступ к BT вручную - может помочь с QPython?

Изменено пользователем Lobster66

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Shr-lnm    859
3 hours ago, Lobster66 said:

А если сделать ROOT и дать полный доступ к BT вручную - может помочь с QPython?

Про ROOT не подскажу - не пробовал. 

Про манифест в qpython вот статья https://shaneormonde.wordpress.com/2014/03/30/qpython-bluetooth-patch/ 

и в конце там есть apk, но тоже не пробовал....

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Lobster66    0
11 часов назад, Shr-lnm сказал:

Про ROOT не подскажу - не пробовал. 

Про манифест в qpython вот статья https://shaneormonde.wordpress.com/2014/03/30/qpython-bluetooth-patch/ 

и в конце там есть apk, но тоже не пробовал....

Забил на W732, установил на планшет. Спасибо за помощь!

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Alеxey    7

сегодня встретился с человеком, у которого лагуна 2 ф1, и его елм и ноут.

у него дизель и в своей авто он веидит все блоки, в его же логе есть ответ на кан шину, но запрос не как у меня.
подключился ко мне в авто и опять 6 блоко и кан еррор в логе.
 

собсно я что думаю, какой то косяк в скрипте или где то, кан запросы на совпадают с моим авто.

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или авторизуйтесь, чтобы оставить комментарий

Комментарии могут оставлять только зарегистрированные пользователи

Создать аккаунт

Зарегистрировать новый аккаунт в нашем сообществе. Это несложно!

Зарегистрировать новый аккаунт

Войти

Есть аккаунт? Войти.

Войти